Nodejs 4.0 来,pomelo计划支持不?

话说pomelo上个稳定还是0.10.x
现在跳过了0.12.x, iojs 1.x 2.x 3.x
升级到4.0应该得支持吧,不然内核性能等差太多了。

标签: pomelo
roytan 在 2015-9-9 17:08发布 分享到 weibo
5 回复
#1 fantasyni 2015-9-9 18:09 回复

把c++模块都干掉,没啥问题

#2 {3} wangxy 2015-9-10 16:10 回复

@roytan

在我们的2.0计划里面

在2.0的计划里面, 我们打算对代码进行改进优化,引入ES6的特性,特别是开启use strict;
对于部署,启动方式,以及运维方面都会进行优化;

xykong 2015-9-10 17:08 回复

2.0 计划有时间表和路线图公布吗?

andyleesharp 2015-9-15 14:01 回复

十分期待,希望我们下一款游戏能用上

newebug 2015-9-22 23:07 回复

牛到不行,万众期待!

语言特性步子不要迈太大了,以免扯着蛋,希望能重点优化 rpc 性能,这个确实成瓶颈了。

#3 {2} rain1017 2015-9-10 23:05 回复

Node4.0可以跑pomelo,需要升级pomelo-admin里面heapdump的版本

tableman 2015-9-14 11:03 回复

怎么做到哈

smilence 2015-11-3 11:06 回复

为了使用pomelo list等命令,在node4.2下安装全局pomelo报错,安装命令:npm install -g pomelo --registry https://registry.npm.taobao.org

从错误来看确实是 heapdump 引起的,pomelo-admin使用heapdump是 v0.3.7,而官方 heapdump 最新版本也是 v0.3.7,请问怎么升级?

https://github.com/bnoordhuis/node-heapdump/releases

#4 {2} zaoli 2015-9-23 15:52 回复

新版pomelo已经可以了

zfree 2016-10-31 17:45 回复

请问如何操作? .0.9.16@socket.io-client依赖的.0.8.0@ws一直编译不过去

zfree 2016-10-31 17:47 回复

写错是.0.4.32@ws一直编译不过去

#5 a447450190 2016-3-25 11:14 回复

现在node 用那个版本?

回到顶部